Apps Disappearing at the Start of the Day

Issue / Question

  • My app(s) seem to always disappear or close by themselves at the beginning of the day!
  • Citrix apps suddenly disappear or close

Cause

This is because of the way Citrix works, and proves that the order in which we perform operations is very important.  When you open your first app, Citrix creates a "session".  When you close all your apps, Citrix says "Ok, I'm going to close your session". While Citrix is closing your session, there is this short grace period where you can open new apps on the old session that is already in the process of closing.  So if, for example, you start your day by opening E-Time, then you clock in, close E-Time, and then open some other app (such as Siebel/Outlook), Citrix will continue closing your session, even though you clicked a new app.

Resolution

There are a few ways to prevent this from happening. The easiest resolution is for you to always start your day by opening an app that you plan to keep open for a while, such as Outlook, Siebel, or the Interaction Client.  An alternative is to continue to open the same app, but keep it active until you have opened a second app as well.

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